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1 Overview
NDEV software is a program that uses the files stored on a PC to emulate Revolution discs. By using

the PC files as they are, without building a Revolution disc image, NDEV software can make

debugging more efficient.

In addition, NDEV software supports emulation with an access speed that is close to the actual Wii

optical disc drive speed. (This feature can be enabled or disabled. Disabling this feature enables

high-speed debugging that ignores read rates.) 
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2 Operating Environment

2.1 Operating Environment

NDEV software requires the following operating environment to use NDEV software.

• A PC running Windows XP Home/Professional (SP2 or later)

• At least three free USB 2.0 interfaces

• At least one free serial port

• Approximately 9 GB of hard disk space

• At least 256 MB of RAM memory

2.2 System Configuration

Figure 2-1 System Configuration

Host PC (NDEV Software)
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Serial Cable

Television Monitor
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2.3 Directory Structure

Shown below is the NDEV software directory structure after the installation.

<Installation Directory>/

|

+--bin/ NDEV software
| |

| +--NdevRun-Tmp/ Working directory for NdevRun.exe
|

+--lib/ Libraries for Revolution

2.3.1 bin : NDEV Software

Optical Disc Drive Emulator

ODEM.exe Optical disc drive emulator

Layout Management Tools

NdevMakeDlf.exe Application used for creating disc layout information

SetNdEnv.exe Application used for setting the NDEV software environment

GetNdEnv.exe Application used for getting the NDEV software environment

NdevRun.exe Application used for simplifying the optical disc drive emulator startup

NdevRun.ddf Default definition file used by NdevRun.exe to create disc layout information

ndrun.bat Batch file used for starting the optical disc drive emulator

ndstop.bat Batch file used for terminating the optical disc drive emulator

ndrun Shell script used for starting the optical disc drive emulator (for Cygnus tools)

ndstop Shell script used for terminating the optical disc drive emulator (for Cygnus

tools)

ddfEditor.exe Application used for creating the .ddf file

2.3.2 bin/NdevRun-Tmp : NdevRun.exe Working Directory

This is the working directory for NdevRun.exe.

2.3.3 lib : Revolution Libraries

Use the Revolution NdevExi2.a and NdevExi2D.a libraries for running CodeWarriorTM in NDEV.
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3 Files Created and Used by NDEV Software

3.1 Application Input and Output Files

Figure 3-1 Application Input and Output Files
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3.1.1 Definition File for Disc Layout Information (.ddf)

NdevMakeDlf.exe references this definition file when it creates the .dlf, .dsf, and .rcf files. For

more information, see Appendix A Format of the Definition File Used for Creating Disc Layout

Information.

3.1.2 Disc Layout File (.dlf)

This is the disc layout file for ODEM.exe, which performs emulation using the .dlf, .dsf, and .rcf

files, as well as the files specified within the .dlf files.

3.1.3 Disc System File (.dsf)

This is the disc system file for ODEM.exe. This binary file comprises the DiskID, DiskInfo, BB1,

BB2, BI2, FST, and the boot *.dol files. ODEM.exe performs emulation using the .dlf, .dsf,

and .rcf files, as well as the files specified within the .dlf files. 

3.1.4 Revolution Config File (.rcf)

This is the configuration file for ODEM.exe, which performs emulation using the .dlf, .dsf

and .rcf files, as well as the files specified within the .dlf file.

3.1.5 Master Binary File (.rvm)

This is the format in which the mastering data is provided.

3.1.6 Multiple Disc Management File (.mdf)

The management file is used when a multiple disc game is started with ODEM.exe. For more

information, see Appendix B, Multiple Disc Management File (.mdf) Format, and Appendix C, Using

Multiple Discs.

Note: At this time, multiple-disc games are not supported.
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4 Using NDEV Software

4.1 NDEV Software

This chapter describes the NDEV software files installed in the bin/ directory.

ODEM.exe Optical disc drive emulator

NdevMakeDlf.exe Application used for creating the disc layout information

SetNdEnv.exe Application used for setting the NDEV software environment

GetNdEnv.exe Application used for getting the NDEV software environment

NdevRun.exe Application used for simplifying the optical disc drive emulator startup

NdevRun.ddf Default definition file used by NdevRun.exe for creating the disc layout information

ndrun.bat Batch file used for starting the optical disc drive emulator

ndstop.bat Batch file used for terminating the optical disc drive emulator

ndrun Shell script used for starting the optical disc drive emulator (for Cygnus tools)

ndstop Shell script used for terminating the optical disc drive emulator (for Cygnus tools)

ddfEditor.exe Application used for creating the .ddf files

4.1.1 ODEM.exe

Synopsis

Optical disc drive emulator for NDEV

Syntax
ODEM <options> <input disc layout file>

Options

-r Resets the NDEV CPU at startup

-f Fast mode (does not emulate seek time or transfer rate)

-i Does not display operation panel at startup

-end Terminates the executing instances of ODEM.exe

-l Loads disc

-s <serial number> Specifies the serial number (8 digits) of the NDEV being used

Description

ODEM.exe emulates an optical disc drive by using the disc layout information created by

NdevMakeDlf.exe. To start the optical disc emulator, use the command line or click the application

icon. After startup, the icon appears in the status area (system tray), and Control Panel appears as

shown in Figure 4-1. Use Control Panel to issue basic optical disc drive emulator commands.
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Figure 4-1  Control Panel

If you use the command line, and if the path name includes spaces for the specified disc layout file,

the entire path name must be enclosed in double quotation marks (for example, ”/path name”).

If two NDEV devices are connected to the PC, a dialog box used for selecting the NDEV serial

number will appear at startup. (If you specify option –s from the command line, the Device List

dialog box will not be displayed.)

Figure 4-2  Dialog Box Used for Selecting an NDEV Serial Number

Select the NDEV serial number and click OK.

4.1.1.1 Operating Procedures

Up to the game program execution, the operating procedures for the optical disc drive emulator and

the Wii console are the same.

Table 4-1 Operating Procedures for the Optical Disc Drive Emulator and the Wii Console

Actual Game Console Optical Disc Emulator

Load disc Select and load disc layout file

Eject disc Eject disc

Reset Reset

When you execute the game program software, be sure to follow the operating procedures.
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Executing from the Control Panel

Select disc 
layout file

�
Load disc

�
Reset  

Executing from the Command Line
>ODEM –l –r disc_layout_file [ENTER]

4.1.1.2 Control Panel

The menu and the toolbar of Control Panel allow you to use every feature of the optical disc

emulator. The current status is always displayed on Control Panel as a toolbar button.

Figure 4-3 Control Panel

Opening a Disc Layout File

This feature selects the disc layout file. The name of the currently selected disc layout file appears in

the title bar.

Method of Operation

On the File menu, click Open Disk Layout File. Alternatively, on the toolbar, click .

Opening Recent Disc Layout Files

This feature allows you to select the disc layout file from the most recently used files.

Method of Operation

On the File menu, click Recent Disk Layout Files.
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Restarting the Emulator

This feature restarts the optical disc drive emulator.

Method of Operation

On the File menu, click Restart Emulator.

Cancelling the Emulator

This feature cancels the optical disc drive emulator.

Method of Operation

On the File menu, click Cancel Emulator.

Exiting the Emulator

This feature exits the optical disc drive emulator.

Method of Operation

On the File menu, click Exit.

Emulation Error Settings

You can enable or disable the emulation of the FATAL and RETRY errors. When the emulation is enabled,

a check mark appears in the menu and the disc read command errors are returned. These errors are used

for debugging when the disc data cannot be read properly due to scratches on the disc, for example.

Method of Operation

On the Setting menu, click Retry Error Emulation. Alternatively, on the toolbar, click .

On the Setting menu, click Fatal Error Emulation. Alternatively, on the toolbar, click .

Icon Status

RETRY error emulation is enabled

FATAL error emulation is enabled

Emulation for both errors is disabled
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Seek Time Emulation Setting

Seek time emulation can be enabled or disabled. When enabled, a check mark appears in the menu.

The emulated access speeds are close to those of the actual Wii optical disc drive.

Method of Operation

On the Settings menu, click Seek Time Emulation. Alternatively, on the toolbar, click .

Icon Status

Seek time emulation is enabled

Seek time emulation is disabled

Note: Even though this is called “Seek Time Emulation,” only the READ times are emulated, not the

SEEK times.

Eject/Load Disc

This feature ejects and loads the disc. The Open Disc Layout File icon is enabled while the disc is

being ejected and disabled while the disc is being loaded.

Method of Operation

On the Operation menu, click Eject/Load. Alternatively, on the toolbar, click .

Open Disc Layout File Icon Status

: Ejecting disc

: Loading disc

Pause

If you click and hold this button, disc access will not return a response. This feature is used to check

the game behavior when the disc access is slow.
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Method of Operation

On the toolbar, hold down .

Reset

This feature resets the NDEV CPU.

Method of Operation

On the Operation menu, click Reset. Alternatively, on the toolbar, click .

Console Reset

This feature functions the same way as the CONSOLE RESET switch on the NDEV console.

Note: Console Reset functions the same way as the reset switch on the Wii console.

Note: Console Reset is a software reset. When the Reset switch is used, the application performs

the processing.

Method of Operation

On the Operation menu, click Console Reset. Alternatively, on the toolbar, click .

Display Log

This feature turns on or off the log viewer display. When the log viewer is being displayed, a check

mark appears next to the corresponding command.

Method of Operation

On the Display menu, click Display Log. Alternatively, on the toolbar, click .

Minimizing the Control Panel in the Status Area

This feature minimizes Control Panel in the status area.

Method of Operation

On the toolbar, click .
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About OpticalDiskEmulator

This command displays a dialog box that provides the version and other information about the optical

disc drive emulator.

Method of Operation

On the Help menu, click About OpticalDiskEmulator.

4.1.1.3 Status Area Icon

The status area icon indicates that the optical disc drive emulator is minimized.

Figure 4-4 Status Area Icon When the Optical Disc Drive Emulator is Minimized

To open a shortcut menu, right-click on the status area icon. From this shortcut menu, you can select

the optical disc drive emulator commands. To maximize or minimize Control Panel, double-left-click

on the status area icon.

Control Panel Display

This feature turns on and off the display of the Control Panel. When Control Panel is displayed, a

check mark appears next to the corresponding command.

Method of Operation

On the shortcut menu, select Control Panel.

Note: Other commands on the shortcut menu are the same as the corresponding commands on the

Control Panel menu.

4.1.1.4 Log Viewer

The log viewer displays an operation log from the time the optical disc drive emulator is executed until

it is terminated. However, if the number of entries exceeds a certain limit, older log entries are not

displayed.
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Figure 4-5 Log Viewer

Clear Display Log

This feature clears the currently displayed log.

Method of Operation

On the Edit menu, click Clear Log. Alternatively, on the toolbar, click .

Save Log to a File

This feature writes to a file all the log information recorded by the optical disc drive emulator.

(This includes the entries that are no longer displayed in the log viewer.)

Method of Operation

On the Edit menu, click Save Log. Alternatively, on the toolbar, click .

4.1.2 NdevMakeDlf.exe

Synopsis

This application allows you to create the disc layout information.

Syntax
NdevMakeDlf [ options ] [ <input file1> [<input file2>] [<input file3>] ]

Options

-v Displays version information

-? Displays help messages
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Description

This application creates the disc layout information from the specified .ddf (disc definition file) input

files. Up to three .ddf files can be specified from the command line at once. If the same sections or

variables are defined for the .ddf file that has been specified more than once, the content of the file

that was specified last will be given the priority. (<input file3> has the highest processing priority.) 

For more information about the .ddf file content, see Appendix A Format of the Definition File Used

for Creating Disc Layout Information.

NdevMakeDlf.exe creates the following files.

.dlf (disc layout file)

.dsf (disc system file)

.rcf (Revolution configuration file)

To operate, the optical disc drive emulator references a .dlf (disc layout file) output by

NdevMakeDlf.exe.

4.1.3 SetNdEnv.exe

Synopsis

This application is used for setting the NDEV software environment.

Syntax
SetNdEnv [-options ] [ <Name> <Data> ]

Options

-v Display version information

-? Display help messages

Description

This application stores the NDEV software environment settings in the registry.

When a .dlf (disc layout file) is created from a .ddf (disc define file), NdevMakeDlf.exe

references the values set by this application.

When NdevMakeDlf.exe is executed, the string ${<Name>}, written in the .ddf file, is converted

to <Data>.

In the NdevRun.ddf file, which is used by NdevRun.exe, the [Input] section defines DvdRoot.

[Input]

DvdRoot=${DvdRoot}

When a .dlf is created and ODEM.exe is executed with NdevRun.exe, you must set DvdRoot with

SetNdEnv.exe.

When <Name> is specified without <Date>, the <Name> settings are deleted from the registry.
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4.1.4 GetNdEnv.exe

Synopsis

This application gets the NDEV software environment and displays the environment on the screen.

Syntax
GetNdEnv [-options ]

Option

-v Display version information

-? Display help messages

Description

This application gets the NDEV software environment from the registry and displays the environment.

4.1.5 NdevRun.exe

Synopsis

This executable simplifies the optical disc drive emulator startup by creating a disc layout file and

running ODEM.exe/makervm.exe.

Syntax
NdevRun {<options>} [<Revolution .elf file>] {<options>} <-a argument list…>

Options

-t｜-t=<num> Set arguments for debugging

-d=<.ddf file> Specify a .ddf file

-n Do not wait for termination of ODEM.exe (must specify with –e)

-f Run ODEM.exe in the high speed mode (must specify with –e)

-o Put output file in the NdevRun.exe working directory

-e Execute ODEM.exe

-m=<output master image file> Execute makervm.exe

-a Specify the argument list
(All arguments listed after this option will be passed to the
application.)

-w Move to the directory location where .elf files are specified as
arguments

-v Display version information

-s=<s/n> Specify the NDEV serial number (8 digits) to be used
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Description

The following points describe NdevRun.exe functions.

1. Uses makedol.exe to convert the .elf file indicated as an argument to a .dol file.

NdevRun-Tmp/NdevRun.dol is created in the directory where NdevRun.exe is located.

2. Uses NdevMakeDlf.exe to create a .dlf file for ODEM.exe.

The default definition file (.ddf) references NdevRun.ddf in the directory where

NdevRun.exe is located.

After NdevRun.ddf is read, if the directory that contains the .elf file specified as an

argument also contains a file with the same name but a .ddf extension, that file is read

next. If this .ddf file and NdevRun.ddf both contain the same definitions, the .ddf file

definitions take priority.

3. If -d=<ddf file> is specified, the specified .ddf file is read.

If the directory that contains the .elf file specified as an argument also contains a file

with the same name but a .ddf extension, the warning message (shown in the example

below) is displayed and the .ddf file is ignored.

Example:

Warning: Instead of bins/sample0.ddf, the bins/test.ddf specified by -d=<ddf

file> will be used.

sample0.ddf The .ddf file that has the same name as the .elf file

test.ddf The .ddf file specified using the -d option

Note: NdevRun.exe displays the .ddf being used when the .dlf file is created.

4. If -m=<output master image file> is specified, marvm.exe is started and the master

data format files are created.

5. If -e is specified, ODEM.exe is started.

4.1.6 NdevRun.ddf

Synopsis

This is the default definition file for creating the disc layout information used by NdevRun.exe.

Description

This file defines the default values for creating the disc layout information used by NdevRun.exe.

This file is used if the –t option is not specified in NdevRun.exe.
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4.1.7 ndrun.bat

Synopsis

This batch file is used for starting the optical disc drive emulator.

Description

This batch file is used for starting the optical disc emulator. NdevRun.exe starts this file internally.

4.1.8 ndstop.bat

Synopsis

This batch file is used for terminating the optical disc drive emulator.

Description

This batch file runs NdevRun.exe and is used for terminating the optical disc drive emulator.

4.1.9 ndrun

Synopsis

This shell script for Cygnus tools is used for starting the optical disc drive emulator.

Description

This shell script for Cygnus tools is used for starting the optical disc drive emulator. NdevRun.exe

starts this file internally.

4.1.10 ndstop

Synopsis

This shell script for Cygnus tools is used for terminating the optical disc drive emulator.

Description

This shell script for Cygnus tools is used for terminating the optical disc drive emulator.

NdevRun.exe starts this file internally.

4.1.11 ddfEditor.exe

Synopsis

This application provides a GUI for creating and editing .ddf files, which are the definition files for

creating the disc layout information used by the optical disc drive emulator. This application can be

used to add or modify the following data in the .ddf files.
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• DvdRoot in the [Input] section

• [DiskID] section

• [LBAAlign] section

• [Layout] section

• [BI2] section (CountryCode only)

4.1.11.1 Main Dialog Box

From this dialog box, you can run such commands as exiting the application, creating files, and

selecting files for editing or saving. You can drop files onto the dialog box.

Figure 4-6 Main Dialog Box

About the Window Title

The window title displays the full pathname of the .ddf file that is currently open. If no files are open,

“No File” is displayed.

Creating New Files

To create a .ddf file that has the same name and location as the selected .elf file, click New File

on the File menu. If a .ddf file with the same name already exists in the directory, a dialog box will

appear to confirm that you want to overwrite that file. Even if you choose to overwrite the file here, the

original file will not be overwritten unless you click Overwrite on the File menu.

Editing Files

On the File menu, click Open and select the .ddf file to edit. Once you select a .ddf file, the file

edit dialog box appears.
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Figure 4-7 File Edit Dialog Box

Saving Files

When creating or editing files, the operation File → Save as becomes available only when proper

values are entered for all the fields required for a .ddf file. To overwrite a file, click Overwrite on the

File menu. The file will not be created or overwritten until you select this command.

Closing Files

This item can be selected if a .ddf file has been opened from the File menu, using New File or

Open. Selecting one of these commands will close an open .ddf file. If an open .ddf file contains

unsaved changes, a message box for confirming file closure will appear.

Resetting Initial Values

This command can be selected even if a single data setting has been changed with the file edit dialog

box. When you select this command, the data in the edited .ddf file will be reset to the initial values

and saved to the hard disk.
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Help

This command opens the application help file.

Properties

This command reopens the edit dialog box (Figure 4-7) that was opened automatically along with the

file.

Exiting the Application

To quit the application, click Exit on the File menu or click Exit. If an open .ddf file contains unsaved

changes, a message box for confirming file closure will appear.

4.1.11.2 Edit Dialog Box

Use the edit dialog box to input and to change the data in .ddf files.

Figure 4-8 Edit Dialog Box (DiskID Tab)

OK Button

Click this button to check the format and to reflect the changes in the data. The dialog box will close.

Changes are applied to the data that passes the format check. An error message is displayed for the
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data that fails the format check, and the focus shifts to the fields that have errors.

Note: Data can only be written to the file if you select Overwrite on the File menu. In addition, you

can select Overwrite only if no format errors exist.

Cancel Button

Click this button to cancel all changes. The dialog box will close. This will restore the data to the state

that existed before you opened the dialog box.

DiskID Section Tab

All items in the DiskID section can be changed (see Figure 4-8). If you enter improper values for any

item, you will not be able to edit the remaining items or to save the .ddf file.

Input Format

Proper values must be entered for all items in the DiskID section.

GameName Must be 4 bytes. Only the ASCII codes A-Z, a-z, and 0-9 can be used.

Company Must be 2 bytes. Only the ASCII codes A-Z, a-z, and 0-9 can be used.

DiskNumber Value from 0 to 98, in decimal notation. Must be less than TotalDisk.

GameVersion Value from 0 to 99, in decimal notation.

DiskInfo 64 or fewer bytes of the ASCII code alphanumeric characters.

TotalDisk Value from 1 to 99, in decimal notation.

Input Section Tab

Use this tab to change the value of DvdRoot. You cannot input the directory path directly. To find the

DvdRoot, browse for it in the directory access dialog box. To clear DvdRoot, click Cancel.

BI2 Section Tab

Even though there is a field to specify a CountryCode, the application’s country code cannot be

configured here. You must use setcountrycode in the Revolution SDK to set the country code.
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Figure 4-9 Edit Dialog Box (BI2 Tab)

LBAAlign Section Tab

Under the LBAAlign tab, you can insert, delete, re-order, or change the values for Priority,

FileName, and LBAAlign.
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Figure 4-10 Edit Dialog Box

Insert Data

From the list box, choose where you want to insert the data. Right-click to bring up the shortcut menu,

and select Insert New. New data will be created, with the initial values set for Priority, FileName,

and LBAAlign. Specify a proper value for each field, and click Update to insert the data. Alternatively,

while nothing is selected in the list box enter the values into the empty edit boxes, then insert the data

by clicking Add New Data.

Delete Data

From the list box, select the data for deletion, right-click, and from the shortcut menu select Delete.

Sort Data

To rearrange the data order, drag it within the list box. Inside the same box, you can also select the

data that you want to move. Right-click, and select Cut from the shortcut menu that appears. Select

where to move the data, then right-click and select Paste from the shortcut menu.

Change Values

Select the data whose values you want to change. The values will display in the edit dialog box. To



NDEV Software Manual

RVL-06-0029-001-I 28  2006-2008 Nintendo
Released: July 29, 2008 CONFIDENTIAL

change the values, edit them and click Update. Even if you do not click Update, the changed values

will update automatically when you select other data from the list box.

Input Format

Priority Value from 0 to 2147483647, in decimal notation

FileName Characters that can be used in a file name (cannot use a 2-byte code)

LBAAlign Value that can consist of numeric digits 0-9 and A-F, in Hexadecimal notation

Layout Section Tab

The Layout section can be edited only if DvdRoot has been set in the Input section. You can insert,

delete, or sort the data from the file list under the DvdRoot directory. You can also input the data

directly and make specifications using wildcards.

Figure 4-11 Edit Dialog Box (Layout)

Inserting Data from the DvdRoot File List

From the DvdRoot file list, select the file to insert and click for the inner or outer track list box.
The same command is executed by right clicking on the selected file, and by clicking Move to inner

list or Move to outer list on the shortcut menu.
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Delete Data

From the inner list, outer list, or the wildcard list box, select the data for deletion, right-click, and on

the shortcut menu that appears click Delete. Data deleted from the inner or outer list box will return to

the DvdRoot file list box.

Sort Data

If sorting is performed in the list box of the inner or outer lists, it is possible to sort by dragging the

data within the list box.

To sort data, drag it inside the inner or outer list box. Select the data for moving and click or
to move it between the inner and outer list boxes.

Create Data Using Wildcards

If you want to use wildcards (* or ?) in the FileName field, you must use a keyboard to enter all

values for Priority, FileName, and Layout. To create new data, in the list box select the insertion

location for the new data, right–click, and on the shortcut menu that appears click Insert. Enter the

proper values for all fields and click Change to insert the new data.

Input Format Data Using Wildcards

Priority Value in Decimal notation from 0 to 2147483647

FileName Character string including wildcards that can be used as a file name

Layout Numeric value

4.1.11.3 Changing the Window Size

The window size for ddfEditor.exe can be changed by setting values in ddfEditor.ini.
[ddfEditor]

Width=800

Height=600

The window’s width and height are set by Width and Height, respectively. Dimensions smaller than

800x600 cannot be used and will automatically be corrected to 800x600 if they are specified. An

800x600 window will be displayed if no ddfEditor.ini file exists.

4.2 Running and Debugging Demos

4.2.1 Running Revolution SDK Demo Programs Under NDEV

1. Run GetNdEnv.exe and check that DvdRoot is set to the dvddata directory in which the

Revolution SDK is installed. If DvdRoot is not set to this directory, execute SetNdEnv.exe

and make this setting.

Example: Running SetNdEnv.exe with the Revolution SDK installed in F:\RVL_SDK:

SetNdEnv DvdRoot F:\RVL_SDK\dvddata
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2. Specify the Revolution .elf file to be executed and run NdevRun.exe; for example:
NdevRun -e XXXX.elf

4.2.2 Debugging Revolution SDK Demo Programs Under NDEV

1. Run GetNdEnv.exe and check that DvdRoot is set to the dvddata directory in which the

Revolution SDK is installed. If DvdRoot is not set to this directory, execute SetNdEnv.exe

and make the setting.

Example: Running SetNdEnv.exe when the Revolution SDK is installed in F:\RVL_SDK:
SetNdEnv DvdRoot F:\RVL_SDK\dvddata

2. Move to the Revolution SDK build\demos directory and rebuild.

Examples: Running make when rebuilding:

make (when making a debug build)

make NDEBUG=1 (when making a release build)

3. Start the CodeWarrior IDE. On the Edit menu, click Preferences. In the dialog box, click

Source Trees and set RevolutionRoot as the name of the directory where the

Revolution SDK is installed.

4. Read the .elf file to debug from the IDE.

5. On the Project menu, click Debug from the IDE to start debugging.

Note: When an error occurs in the CodeWarrior IDE during debugging:

Depending on the PC environment, the following error may be displayed:

"Load script process returned error. (-1)"

You will not be able to debug in this case. If this problem occurs, change the

CodeWarrior settings as shown below. In the CodeWarrior’s [Debugger] – [Debugger

Settings], under Load Script add -*=5 to ndrun as follows:
ndrun.bat -*=5 $F $P

In the unlikely event that the problem persists even after the settings have been

changed this way, try to specify a number larger than 5.
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Appendix A Format of the Definition File Used for

Creating Disc Layout Information
Definition files used for creating disc layout information are referenced by NdevMakeDlf.exe, the

tool that creates the disc layout information.

A.1 Basic Notation

Definition files for creating disc layout information are written according to the following rules.
[<section name 1>]

<name11>=<value 11>

<name12>=<value 12>

<name13>=<value 13>

.

.

[<section name 2>]

<name21>=<value 21>

<name22>=<value 22>

<name23>=<value 23>

.

.

[<section name N>]

Values can be replaced using environment variables. Be sure to write this in the following form.
$(variable-name)

Example:
[Input]

DvdRoot="$(MY_DVDDATA)"

Values can be modified by values set using SetNdEnv.exe. This is written in the following form.
${variable-name}.

Example:
[Input]

DvdRoot="${DvdRoot}"

A.2 Section Notation

Note that in the [LbaAlign], [SizeAlign], and [Layout] sections, wildcards can be used in

<FileName>. “*” matches any number of characters, and “?” matches any single character in a

filename.
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A.2.1 [Input] Section

DvdRoot="<Root Directory>"

• Name of the directory that stores the files to emulate

• A table to create the FST file is generated by searching files inside the directory specified here

LDRFileName="<LDR File Name>"

• Filename of Application Loader

BI2FileName="<BI2 File Name>"

• Name of the BI2 file

BootFileName="<Boot File Name>"

• Name of the program file to execute

• Specify the .dol file created by makedol.exe in the Revolution SDK

RVLSysFileName="<Revolution System File Name>"

• Revolution system file name

Example:
[Input]

DvdRoot="${DvdRoot}"

LDRFileName="$(REVOLUTION_SDK_ROOT)\RVL\boot\apploader.img"

BI2FileName="$(REVOLUTION_SDK_ROOT)\x86\bin\bi2.bin"

BootFileName="Sample.dol"

RVLSysFileName="$(REVOLUTION_SDK_ROOT)\x86\bin\rvl.bin"

A.2.2 [Output] Section

LayoutFileName="<output Dlf-File>"

• Disc layout file name

SystemFileName="<output Dsf-File>"

• Disc system file name

ConfigFileName="<output Rcf-File>"

• Configuration file name

Mode=<Output Mode>

• Specify the output mode using one of the following strings

RVL Revolution mode

GC Nintendo GameCube compatibility mode
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NdevMakeDlf.exe changes the output format of the .dlf (disc layout) file and the .dsf (disc

system) file according to the output mode defined here. If the Nintendo GameCube compatibility

mode has been specified as the output mode, a .rcf (configuration) file will not be output. If the

output mode is undefined, files are processed in the Revolution mode.

Example:
[Output]

LayoutFileName="Sample.dlf"

SystemFileName="Sample.dsf"

ConfigFileName="Sample.rcf"

Mode=RVL

A.2.3 [DiskID] Section

GameName=<Game Name>

• Four-byte ASCII code game name supplied by Nintendo

Company=<Company Name>

• Two-byte ASCII code company name supplied by Nintendo

DiskNumber=<Disc Number>

• Disc number information for multiple disc games

• Numbers are set beginning from zero. Use zero for games that do not use multiple discs. 

GameVersion=<Game Version>

• Game version number

DiskInfo="<Long Game Name>"

• Game name character string for confirming data. This is an alphanumeric ASCII string with a

maximum length of 64 characters.

TotalDisk=<Total Disk Number>

• Total number of discs

Example:
[DiskID]

GameName=”RELS”

Company=”AB”

DiskNumber=0

GameVersion=0

DiskInfo="Sample Game Name"

TotalDisk=1
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A.2.4 [BB2] Section

FSTMaxLength=<size>

• Memory size allocated for FST
FSTAddress=<address>

• Address of the FST location

• Used when making specifications with the start address

FSTEndAddress=<address>

• Address of the FST location

• Used when making specifications with the end address

FSTuserTop=<lba>

• Start of the user area

• When omitted, set to the start of the available free area

FSTuserEnd=<lba>

• End of user area

Example:
[BB2]

FSTMaxLength=0x080000

FSTEndAddress=0x80400000

FSTuserEnd=0x57058000

A.2.5 [BI2] Section

DEBUGFLAG=<flag>

• Specify 0 when not using a debugger under NDEV, or specify 3 when using the CodeWarrior

debugger

Example:
[BI2]

DEBUGFLAG=0

A.2.6 [LbaAlign] Section

<Priority>="<File Name>",<LBA Align>

• Aligns the optical disc drive position of the file whose name is set as <File Name> with the

boundary set as <LBA Align>

• This section is used for the files, such as ADPCM data, that have a set start address boundary.

(ADPCM data must be 32KB-aligned.) The <Priority> value determines the evaluation
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priority order; the greater the numeric value, the higher the priority.

Example:

Places "*" at the 32-byte boundary; places "*.adp" at the 32KB boundary.
[LbaAlign]

0="*",32

1="*.adp",0x8000

A.2.7 [Layout] Section

<Priority>="<File Name>",<layout val>

The file whose name is indicated with <File Name> is laid out on the optical disc drive based on the

value of <layout val>. If the value is negative, the file layout starts from the inside of the disc; if

positive, the file layout starts from the outside of the disc. The purpose of this is to lay out files on the

outer edge of the disc, thus reducing the access time.

<Priority> determines the evaluation priority order: the greater the numeric value, the higher the

priority.

Example:

The file layout starts from the inside of the disc, with the .prg files followed by the .bin files. After this,

the file layout starts from the outside of the disc in the following order: .adp files, .mov files, and the

files located in the data directory.

Note: Specifications for the .prg, .bin, .adp, and .mov files located in the directory have a higher

priority than the specifications for the files located in the data directory:

[Layout]

1="*.prg",-2 

1="*.bin",-1 

0="data/*",1

1="*.mov",2

1="*.adp",3

If multiple files have the same <layout val>, the files are laid out in the listed order.

Example:

File layout moves toward the outer edge of the disc in the following order: foo.dat, baa.dat, and

aaa.dat, where aaa.dat is the closest to the disc’s outer edge.

[Layout]

1="foo.dat",1

1="baa.dat",1

1="aaa.dat",1
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A.2.8 [PathList] Section

<Name>="<FST Directory>","<Windows Directory >"

Register <Windows Directory> for the <FST Directory>. This method is used when the data is

put in a location other than the directory denoted by DvdRoot in the [Input] section, or when multiple

discs are used and a shared directory is specified. Note that when multiple discs are used, it is more

convenient to include a specification in mdf. You can assign any value to <Name>. (<Name> is used

internally by NdevMakeDlf.exe for management purposes only.) If the same management name is

assigned, the latter specification will be enabled.

Example:
[PathList]

ROOT2=”ROOT2”, “C:\ROOT2\dvddata”

A.2.9 [LbaOrigin] Section

<LBA>="<Base File Name>",<layout type>

The file specified by <Base File Name> is laid out in <LBA> on the optical disc. For <layout type>,

use ‘+’ or ‘-’. When ‘+’ is used, files are laid out in the positive direction, beginning at <LBA> and

continuing toward the outside of the disc. When ‘-’ is specified, files are laid out in the negative

direction, beginning at <LBA> and continuing toward the inside of the disc. Wildcards cannot be

specified for <Base File Name>.

<LBA>::"<File Name>"

The file designated by <File Name> is laid out on the optical disc after the file designated by <Base

File Name>, which was defined in <LBA>="<Base File Name>", <layout type>. Wildcards

cannot be specified for <File Name>. <LBA> must be already defined.

Example:
[LbaOrigin]

0x30000000=”file00”, +

0x30000000::”file01”

0x30000000::”file02”

In this example, the layout of the specified file is as shown in the figure below.
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Figure Error! No text of specified style in document.-1 Layout Based on the [LbaOrigin]

Specification

"file00"

alignment

"file01"

alignment

"file02"

alignment

：

：

0x30000000

Example:
[LbaOrigin]

0x50000000=”file10”, -

0x50000000::”file11”

0x50000000::”file12”

In this example, the layout of the specified file is as follows.

Figure Error! No text of specified style in document.-2 Layout Based on the [LbaOrigin]

Specification

"file12"

alignment

"file11"

alignment

"file10"

alignment

：

：

0x50000000
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A.2.10 [LayoutOff] Section

<File Name>

• File name

• The file specified by <File Name> is not laid out. (A disc layout file, .dlf, and the file specified

in FST are not output.)

• Wildcards can be specified in <File Name>

Example:
[LayoutOff]

"abc.ecd"

"axdemo\axart\axartdemo.spd"

"axdemo\stream\*.adpcm"

"pictures\*.BMP"

"texts\*"
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Appendix B Multiple Disc Management File (.mdf)

Format
NdevRun.exe references multiple disc management files. The basic notation is the same as that of

the definition files used for creating the disc layout information, and each section can list the same

information. When a game that uses multiple discs is created, the write information is shared with

both the definition file for the disc layout information and the disc list in this file.

Section Description

Note: Sections described in Appendix A have been omitted.

[MultipleDisk] Section
<Disk Number>="<elf File Name>"

• Specifies the .elf file list that corresponds to each disc number

Example:
[MultipleDisk]

0="sample0.elf"

1="sample1.elf"

2="sample2.elf"

3="sample3.elf"
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Appendix C Using Multiple Discs

NDEV Software Features Used for Supporting the Creation of Multiple Discs

1. Update all disc layout information when execution starts.

Disc layout information must be updated whenever file sizes change, even if the number of files

remains the same. With multiple disc games, to avoid any possible problems, all disc layout

information should be updated when execution starts.

2. Adjust the "FST Max Length" value for each disc.

If the FST of the converted disc is larger than the FST of the unconverted disc, it is necessary to

re-allocate the FST area in another memory region. The best way to ensure the efficient use of

the main memory is to specify the same FST Max Length value for each disc.

3. Make shared data directories individually manageable on a PC.

Registering shared directories with the [PathList] section allows you to avoid multiple instances

of shared directories on the PC.

Conditions that Must Be Met to Use these Features

1. For each disc, the following files must be in the same directory: multiple disc management files

(.mdf), Revolution startup program files (.elf), and the definition files for creating disc layout

information files (.ddf).

2. For each disc, the Revolution startup program files (.elf) must be registered in the

[MultipleDisk] section of the multiple disc management file (.mdf).

Items That Are Included in Each Definition File (.mdf and .ddf)

1. In the [MultipleDisk] section of the .mdf files, register the list of .elf files.

2. In the [DiskID] section of the .mdf files, specify a value for TotalDisk.

3. In the [DiskID] section of the .mdf file, enter information if necessary.

4. Using the [PathList] section, register shared directories in the .mdf file.

5. In the .ddf file that corresponds to the .elf file, specify the local DvdRoot for each disc.
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The following is an illustration list of the .mdf and .ddf files.

Example:

Game name: AAA

Company name: HU

Version: 1

DISK count: 4

DISK0 startup program: sample0.elf

DISK1 startup program: sample1.elf

DISK2 startup program: sample2.elf

DISk3 startup program: sample3.elf

DISK0 data directory: C:\Sample\Disk0

DISK1 data directory: C:\Sample\Disk1

DISK2 data directory: C:\Sample\Disk2

DISK3 data directory: C:\Sample\Disk3

Shared data directory: C:\Sample\Share

Shared directories are mapped to SYSTEM on the FST.

Listing
;-- contents of sample.mdf - top --

[DiskID]

GameName=AAAA

Company=HU

GameVersion=1

TotalDisk=4

[MultipleDisk]

0="sample0.elf"

1="sample1.elf"

2="sample2.elf"

3="sample3.elf"

[PathList]

SharePath="SYSTEM","C:\Sample\Share"

;-- contents of sample.mdf - end --

;-- contents of sample0.ddf - top --

[Input]

DvdRoot="C:\Sample\Disk0"

;-- contents of sample0.ddf - end --
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;-- contents of sample1.ddf - top --

[Input]

DvdRoot="C:\Sample\Disk1"

;-- contents sample1.ddf - end --

;-- contents of sample2.ddf - top --

[Input]

DvdRoot="C:\Sample\Disk2"

;-- contents of sample2.ddf - end --

;-- contents of sample3.ddf - top --

[Input]

DvdRoot="C:\Sample\Disk3"

;-- contents of sample3.ddf - end --

Note: DiskNumber in the [DiskID] section does not need to be written to the .ddf for each disc. The

number specified by MultipleDisk in the .mdf file will be used as DiskNumber.

Note: You can specify any name for the .mdf file name. A search is made for all the .mdf files

located in the same directory as the .elf files that NdevRun.exe will execute. A search is

also made for the .mdf files registered in the [MultipleDisk] section by the .elf files that will

be executed.
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Appendix D Using Multiple NDEVs
The NDEV software includes a feature for connecting multiple NDEVs to one PC.

D.1 If Multiple Devices Are Run with ndrun

If multiple NDEVs are run with ndrun and ndstop, the following information should be entered.

a. When a program is run with ndrun

<The first NDEV to run>

>ndrun -s=11111111 filename.elf [ENTER]

<The second and subsequent NDEVs to run>

>ndrun -z -s=22222222 filename.elf [ENTER]

b. When ending a program with ndstop

When using ndstop, the order is irrelevant:

>ndstop -s=11111111 [ENTER]

>ndstop -s=22222222 [ENTER]

or
>ndstop -s=22222222 [ENTER]

>ndstop -s=11111111 [ENTER]

D.2 If Using One of Multiple NDEVs with the CodeWarrior IDE and

the Others with ndrun

At this time, CodeWarrior does not support the connection of multiple NDEVs. However, with the

following procedure, it is possible to use one of the multiple connected NDEVs with the CodeWarrior

IDE.

1. In Load Script, under the CodeWarrior project settings, designate the connected NDEVs in

the order of their serial numbers. Next, confirm the NDEVs that will be run, that is, the NDEVs

that will be recognized.
Load Script: ndrun.bat $F $P -s=XXXXXXXX -$ 

Stop Script: ndstop.bat -s=XXXXXXXX

Normally, the NDEV whose power is turned on first is the NDEV that will be run. Due to the

way in which Windows recognizes NDEV, sometimes an NDEV that was powered on after

the first is run instead. Future revisions will allow you to select the NDEV to use.

2. The NDEV recognized in the preceding step will be used by CodeWarrior.

3. The NDEVs that are run with ndrun are those that were not recognized in CodeWarrior.

Note: If an NDEV ceases to run, try again starting from step 1.
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D.3 About Serial Numbers

The serial number of a production NDEV is the same as that found on the seal on the rear face of the

NDEV. Non-production NDEVs have different serial numbers.

To confirm the serial number, use the serial number selection dialog, which is displayed when

ODEM.exe is run while multiple NDEVs are connected.
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WiiTM and Nintendo GameCubeTM are trademarks of Nintendo.

CodeWarriorTM is a trademark of Freescale Semiconductor, Inc.

Windows is a registered trademark or trademark of Microsoft Corporation in the United States and/or other countries.
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